drvconfig - apply permission and ownership changes to devices
drvconfig [-bn] [-a alias_name] [-c class_name] [-i drivername] [-m major_num] [-r root_dir]
devfsadm(8) is now the preferred command and should be used instead of drvconfig .
The default operation of drvconfig is to apply permission and ownership changes to devices. Normally, this command is run automatically after a new driver has been installed (with add_drv(8)) and the system has been rebooted.
The following options are supported:
Add the name alias_name to the list of aliases that this driver is known by. This option, if used, must be used with the –m major_num, the –b and the –i drivername options.
Add a new major number to name binding into the kernel's internal name_to_major tables. This option is not normally used directly, but is used by other utilities such as add_drv(8). Use of the –b option requires that –i and – m be used also. No /devices entries are created.
The driver being added to the system exports the class class_name. This option is not normally used directly, but is used by other utilities. It is only effective when used with the – b option.
Specify the major number major_num for this driver to add to the kernel's name_to_major binding tables.
Do not try to load and attach any drivers, or if the –i option is given, do not try to attach the driver named drivername.
Perform operations under root_dir, rather than directly under root.
An error occurred.
Device nodes directory
Minor mode permissions
Major number binding
Driver class binding file
See attributes(7) for descriptions of the following attributes: