snmp-notify - SNMP notification daemon for software events
snmp-notify is a daemon that subscribes to software events and FMA diagnosis and repair events and generates SNMP trap notifications based on a set of notification preferences that are stored in the SMF service configuration repository.
SNMP notification preferences are set using svccfg(8).
snmp-notify is managed by the service management facility, smf(7), under the service FMRI:
The following service properties can be set:
This is an astring property that defaults to /. When set, the specified root directory will be used for all pathnames evaluated by snmp-notify.
The following command configures notification preferences for SMF service state transition events.
# svccfg setnotify -g from-online,to-maintenance snmp:activeExample 2 Enabling SNMP Notifications
The following command enables notifications for Fault Management diagnosis events.
# svccfg setnotify problem-diagnosed snmp:activeExample 3 Listing Notification Settings
The following command lists all notification settings for Fault Management diagnosis events.
# svccfg listnotify fma-diagnosis
Refer to svccfg(8) for more information on configuring SNMP notification preferences.
See attributes(7) for descriptions of the following attributes: