inetconv - convertinetd.confentries into smf service manifests, import them into smf repository
inetconv [-f] [-n] [-i srcfile] [-o destdir]
inetconv -e [-n] [-i srcfile]
The inetconv utility converts a file containing records of inetd.conf(5) into smf(7) service manifests, and then import those manifests into the smf repository. Once the inetd.conf file has been converted, the only way to change aspects of an inet service is to use the inetadm(8) utility.
There is a one-to-one correspondence between a service line in the input file and the manifest generated. By default, the manifests are named using the following template:
The <svcname> token is replaced by the service's name and the <proto> token by the service's protocol. Any slash (/) characters that exist in the source line for the service name or protocol are replaced with underscores (_).
The service line is recorded as a property of the converted service.
During the conversion process, if a service line is found to be malformed or to be for an internal inetd service, no manifest is generated and that service line is skipped.
The input file is left untouched by the conversion process.
The following options are supported:
Display a usage message.
Enable smf services which are listed in the input file.
If a service manifest of the same name as the one to be generated is found in the destination directory, inetconv will overwrite that manifest if this option is specified. Otherwise, an error message is generated and the conversion of that service is not performed.
Permits the specification of an alternate input file srcfile. If this option is not specified, then the inetd.conf(5) file is used as input.
Turns off the auto-import of the manifests generated during the conversion process. Later, if you want to import a generated manifest into the smf(7) repository, you can do so through the use of the svccfg(8) utility.
If the –e option is specified, the –n option only displays the smf services that would be enabled.
Permits the specification of an alternate destination directory destdir for the generated manifests. If this option is not specified, then the manifests are placed in /lib/svc/manifest/network/rpc, if the service is a RPC service, or /lib/svc/manifest/network otherwise.
The following command generates smf(7) manifests from newly added lines in inetd.conf(5), places them under /lib/svc/manifest, and then imports them into the smf repository. Use this command if a network application's installation stores the inetd configuration in inetd.conf instead of smf.
# inetconv 100232/10 -> /lib/svc/manifest/network/100232_10-rpc_udp.xml Importing 100232_10-rpc_udp.xml ...Done telnet -> /lib/svc/manifest/telnet-tcp6.xml Importing telnet-tcp6.xml ...DoneExample 2 Generating Manifests for Installation Packages
The following command retrieves inetd service properties from a workspace build directory and places the resulting manifests into the same directory. It does not load the manifests into smf. This command may be useful when porting and packaging a network application for later installation on Solaris.
# BUILDDIR=/export/build/networkapp # inetconv -n -i $BUILDDIR/inet.svcs -o $BUILDDIR networkapp -> /export/build/networkapp/networkapp-tcp.xml
The following exit values are returned:
Operation completed successfully (no errors).
Invalid options specified.
One or more service lines are malformed, and thus no manifest(s) were generated for them.
An error occurred importing one or more of the generated manifests.
A system error occurred.
Default output manifest file name.
See attributes(7) for descriptions of the following attributes: