rpc.ypupdated, ypupdated - server for changing NIS information
ypupdated is a daemon that updates information in the Network Information Service (NIS). ypupdated consults the updaters(5) file in the /var/yp directory to determine which NIS maps should be updated and how to change them.
By default, the daemon requires the most secure method of authentication available to it, either DES (secure) or UNIX (insecure).
On start up, ypupdated checks for the existence of a NIS to LDAP (N2L) configuration file, /var/yp/NISLDAPmapping. If the file is present, ypupdated generates an informational message and exits. ypupdated is not supported in N2L mode.
Accept RPC calls with the insecure AUTH_UNIX credentials. This allows programmatic updating of the NIS maps in all networks.
Accept only calls authenticated using the secure RPC mechanism (AUTH_DES authentication). This disables programmatic updating of the NIS maps unless the network supports these calls.
Configuration file for rpc.updated command.
Configuration file for N2L
See attributes(7) for descriptions of the following attributes:
The Network Information Service (NIS) was formerly known as Sun Yellow Pages (YP). The functionality of the two services remains the same. Only the name has changed. The name Yellow Pages is a registered trademark in the United Kingdom of British Telecommunications PLC, and it must not be used without permission.