network-nfs-cleanup - scheduled service that removes files whose name begins with.nfs.
network-nfs-cleanup is a scheduled service that removes files whose name begins with .nfs. These files are typically created by NFS clients when a process tries to unlink an open file.
For a description of the SMF properties that control when this service runs, see the svc.periodicd(8) man page. These properties may be viewed or modified by using the svccfg command.
This service depends on svc:/network/nfs/server, and will not run if NFS service is disabled.
Earlier releases of the Oracle Solaris removed .nfs files by using a root cron job. When upgrading to a new release, the treatment of this cron job depends on whether local changes have been made to the root crontab. If there have been no local changes, the cron job is removed at upgrade. If there have been local changes to the root crontab but not to this cron job, the first run of the svc:/network/nfs/cleanup-upgrade service will remove the cron job from the root crontab. Otherwise, the first run of the svc:/network/nfs/cleanup-upgrade service will comment out that job and subsequently svc:/network/nfs/cleanup service will place itself into the DEGRADED state during its first scheduled run. After (optionally) changing the schedule of the nfs/cleanup service to match the old cron job, the system administrator can remove the old job from the root crontab. You can use svcadm clear command to move the nfs/cleanup service out of the DEGRADED state.
See attributes(7) for descriptions of the following attributes: