tnctl - configure Trusted Extensions network parameters
/usr/sbin/tnctl [-dfv] [-h host [/prefix] [:template]] [-m zone:mlp:shared-mlp] [-t template [:key=val [;key=val]]] [-HTz file]
tnctl provides an interface to manipulate trusted network parameters in the Solaris kernel.
As part of Solaris Trusted Extensions initialization, tnctl is run in the global zone by an smf(7) script during system boot. The tnctl command is not intended to be used during normal system administration. Instead, if a local trusted networking database file is modified, the administrator first issues tnchkdb(8) to check the syntax, and then refreshes the kernel copy with this command:
# svcadm restart svc:/network/tnctl
See WARNINGS about the risks of changing remote host and template information on a running system.
Delete matching entries from the kernel. The entries will be deleted from kernel cache table that matches the template host type. For example, if the template host type is NETIF, the entry will be deleted from the kernel interface cache; otherwise, the entry will be deleted from kernel host cache. If a template is not specified, tnctl attempts to delete the entry from kernel cache table.
When deleting MLPs, the MLP range must match exactly. MLPs are specified in the form:
Flush all kernel entries before loading the entries that are specified on the command line. The flush does not take place unless at least one entry parsed successfully. Both host cache and interface cache entries are flushed.
Turn on verbose mode.
Update the kernel remote-host cache on the local host for the specified host or, if a template name is given, change the kernel's cache to use the specified template. If prefix is not specified, then an implied prefix length is determined according to the rules used for interpreting the tnrhdb. If –d is specified, then a template name cannot be specified.
Modify the kernel's multilevel port (MLP) configuration cache for the specified zone. zone specifies the zone to be updated. mlp and shared-mlp specify the MLPs for the zone-specific and shared IP addresses. The shared-mlp field is effective in the global zone only.
Update the kernel template cache for template or, if a list of key=val pairs is given, change the kernel's cache to use the specified entry. If –d is specified, then key=val pairs cannot be specified.
Load all template entries in file into the kernel cache.
Load all remote host entries in file into the kernel cache.
Load just the global zone's MLPs from file into the kernel cache. To reload MLPs for a non-global zone, reboot the zone:
# zoneadm -z non-global zone reboot
Trusted network remote-host database
Trusted network remote-host templates
Trusted zone configuration database
Configuration file for the name service switch
See attributes(7) for descriptions of the following attributes:
Changing a template while the network is up can change the security view of an undetermined number of hosts.
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.
The tnctl service is managed by the service management facility, smf(7), under the service identifier:
svcadm restart svc:/network/tnctl
The tnctl command was added to Solaris in Solaris 10 4/08 (Update 5). Prior to that it was included in the Trusted Extensions add-on for Solaris.