vfs_media_harmony - Allow multiple Avid clients to share a network drive.
vfs objects = media_harmony
System Administration tools VFS_MEDIA_HARMONY(8) NAME vfs_media_harmony - Allow multiple Avid clients to share a network drive. SYNOPSIS vfs objects = media_harmony DESCRIPTION This VFS module is part of the samba(7) suite. The vfs_media_harmony VFS module allows Avid editorial workstations to share a network drive. It does this by: 1. Giving each client their own copy of the Avid msmMMOB.mdb and msmFMID.pmr files and Creating directories. 2. Allowing each client to explicitly control the write time the Avid application sees on Avid media directories. This module is stackable. CONFIGURATION vfs_media_harmony automatically redirects requests from clients for Avid database files or an Avid Creating directory to a client-specific version of the file. No configuration beyond enabling the module is needed to get this portion of its functionality working. If Mac and Windows Avid clients will be accessing the same folder, they should be given separate share definitions, with hidden Mac files vetoed on the Windows share. See EXAMPLES. To allow each client to control when the Avid application refreshes their Avid databases, create files for each client and each Avid media directory with the name [avid_dir_name]_[client_ip_address]_[client_username]. To trigger Avid database refreshes, update the write time on those files. See EXAMPLES. It is also necessary for the cache locked write times = no option to be set for clients to be able to control their Avid media folder write times. EXAMPLES Enable media_harmony for Mac and Windows clients: [avid_mac] path = /avid vfs objects = media_harmony cache locked write times = no [avid_win] path = /avid vfs objects = media_harmony cache locked write times = no veto files = /.DS_Store/._@/.Trash@/.Spotlight@/.hidden/.hotfiles@/.vol/ delete veto files = yes Create the files that will allow users david and susan to control their own Avid database refreshes: touch '/avid/OMFI MediaFiles_192.168.1.10_david' \ '/avid/OMFI MediaFiles_192.168.1.11_susan' \ '/avid/Avid MediaFiles/MXF/1_192.168.1.10_david' \ '/avid/Avid MediaFiles/MXF/1_192.168.1.11_susan' Trigger an Avid database refresh for user david: touch '/avid/OMFI MediaFiles_192.168.1.10_david' \ '/avid/Avid MediaFiles/MXF/1_192.168.1.10_david' If you have a large number of Avid media folders to manage, you can give each editor a suitably modified version of examples/scripts/vfs/media_harmony/trigger_avid_update.py to create and update these files. CAVEATS vfs_media_harmony is designed to work with Avid editing applications that look in the Avid MediaFiles or OMFI MediaFiles directories for media. It is not designed to work as expected in all circumstances for general use. For example: It is possible to open a client-specific file such as msmMMOB.mdb_192.168.1.10_userx even though it doesn't show up in a directory listing. VERSION This man page is part of version 4.9.3 of the Samba suite. AUTHOR The original Samba software and related utilities were created by Andrew Tridgell. Samba is now developed by the Samba Team as an Open Source project similar to the way the Linux kernel is developed. ATTRIBUTES See attributes(7) for descriptions of the following attributes: +---------------+-----------------------+ |ATTRIBUTE TYPE | ATTRIBUTE VALUE | +---------------+-----------------------+ |Availability | service/network/samba | +---------------+-----------------------+ |Stability | Volatile | +---------------+-----------------------+ NOTES This software was built from source available at https://github.com/oracle/solaris-userland. The original community source was downloaded from https://download.samba.org/pub/samba/stable/samba-4.9.3.tar.gz Further information about this software can be found on the open source community website at http://www.samba.org/. Samba 4.9.3 01/24/2019 VFS_MEDIA_HARMONY(8)