init - process control initialization
init is the default primordial user process. (Options given to the kernel during boot may result in the invocation of an alternative primordial user process, as described on kernel(8)). init initiates the core components of the service management facility, svc.configd(8) and svc.startd(8), and restarts these components if they fail. For backward compatibility, init also starts and restarts general processes according to /etc/inittab, as described below.
The run levels and system booting descriptions given below are provided for compatibility purposes only, and otherwise made obsolete by the service management facility, smf(7).
If init exits for any reason other than system shutdown, it will be restarted with process-ID 1.
At any given time, the system is in one of eight possible run levels. A run level is a software configuration under which only a selected group of processes exists. Processes spawned by init for each of these run levels are defined in /etc/inittab. init can be in one of eight run levels, 0−6 and S or s (S and s are identical). The run level changes when a privileged user runs /usr/sbin/init.
When the system is booted, init is invoked and the following occurs. First, it reads the properties for the svc:/system/environment:init service. Among these properties are values for locale-related environments, such as LANG or LC_CTYPE . init then looks in /etc/inittab for the initdefault entry (see inittab(5)). If the initdefault entry:
init usually uses the run level specified in that entry as the initial run level to enter only if the options/milestone property has not been specified for svc.startd(8).
The initdefault entry in /etc/inittab corresponds to the following run levels:
init goes to the single-user state. In this state, the system console device (/dev/console) is opened for reading and writing and the command /usr/sbin/su, (see su(8)), is invoked. Use init to change the run level of the system. Note that if the shell is terminated (using an end-of-file), init only re-initializes to the single-user state if /etc/inittab does not exist.
init enters the corresponding run level. Run levels 0, 5, and 6 are reserved states for shutting the system down. Run levels 2, 3, and 4 are available as multi-user operating states.
If this is the first time since power up that init has entered a run level other than single-user state, init first scans /etc/inittab for boot and bootwait entries (see inittab(5)). These entries are performed before any other processing of /etc/inittab takes place, providing that the run level entered matches that of the entry. In this way any special initialization of the operating system, such as mounting file systems, can take place before users are allowed onto the system. init then scans /etc/inittab and executes all other entries that are to be processed for that run level.
To spawn each process in /etc/inittab, init reads each entry and for each entry that should be respawned, it forks a child process. After it has spawned all of the processes specified by /etc/inittab, init waits for one of its descendant processes to die, a powerfail signal, or a signal from another init process to change the system's run level. When one of these conditions occurs, init re-examines /etc/inittab.
New entries can be added to /etc/inittab at any time; however, init still waits for one of the above three conditions to occur before re-examining /etc/inittab. To get around this, init Q or init q command wakes init to re-examine /etc/inittab immediately.
When init comes up at boot time and whenever the system changes from the single-user state to another run state, init sets the ioctl(2) states of the console to those modes saved in the file /etc/ioctl.syscon. init writes this file whenever the single-user state is entered.
When a run level change request is made, init or a designate sends the warning signal (SIGTERM) to all processes that are undefined in the target run level. A minimum interval of five seconds is observed before init or its designate forcibly terminates these processes by sending a kill signal (SIGKILL). Additionally, init informs svc.startd(8) that the run level is changing. svc.startd(8) then restricts the system to the set of services which the milestone corresponding to the run-level change depends on.
When init receives a signal telling it that a process it spawned has died, it records the fact and the reason it died in /var/adm/utmpx and /var/adm/wtmpx if it exists (see who(1)). A history of the processes spawned is kept in /var/adm/wtmpx.
If init receives a powerfail signal (SIGPWR) it scans /etc/inittab for special entries of the type powerfail and powerwait. These entries are invoked (if the run levels permit) before any further processing takes place. In this way init can perform various cleanup and recording functions during the powerdown of the operating system.
You can set default values for environment variables, for such items as time zone and character formatting, in the list of properties for the svc:/system/environment:init service.
init uses pam(3PAM) for session management. The PAM configuration policy, configured in either /etc/pam.conf or per-service files in /etc/pam.d/, specifies the session management module to be used for init. Here is a partial pam.conf file with entries for init using the UNIX session management module.
init session required pam_unix_session.so.1
The equivalent PAM configuration using /etc/pam.d/ would be the following entry in /etc/pam.d/init:
session required pam_unix_session.so.1
If there are no entries for the init service in /etc/pam.conf and no /etc/pam.d/init file exists, then the entries for the “other” service in /etc/pam.conf will be used. If there are not any entries in /etc/pam.conf for the “other” service, then the entries in /etc/pam.d/other will be used.
Go into firmware.
Put the system in system administrator mode. All local file systems are mounted. Only a small set of essential kernel processes are left running. This mode is for administrative tasks such as installing optional utility packages. All files are accessible and no users are logged in on the system.
This request corresponds to a request for smf(7) to restrict the system milestone to svc:/milestone/single-user:default.
Put the system in multi-user mode. All multi-user environment terminal processes and daemons are spawned. This state is commonly referred to as the multi-user state.
This request corresponds to a request for smf(7) to restrict the system milestone to svc:/milestone/multi-user:default.
Extend multi-user mode by making local resources available over the network.
This request corresponds to a request for smf(7) to restrict the system milestone to svc:/milestone/multi-user-server:default.
Is available to be defined as an alternative multi-user environment configuration. It is not necessary for system operation and is usually not used.
Shut the machine down so that it is safe to remove the power. Have the machine remove power, if possible.
Stop the operating system and reboot to the state defined by the initdefault entry in /etc/inittab.
The service svc:/system/boot-config:default is enabled by default. When the config/fastreboot_default property is set to true, init 6 will bypass certain firmware initialization and test steps, depending on the specific capabilities of the system.
Process only those /etc/inittab entries having the a, b, or c run level set. These are pseudo-states, which may be defined to run certain commands, but which do not cause the current run level to change.
Enter single-user mode. This is the only run level that doesn't require the existence of a properly formatted /etc/inittab file. If this file does not exist, then by default, the only legal run level that init can enter is the single-user mode. When in single-user mode, the filesystems required for basic system operation will be mounted. When the system comes down to single-user mode, these file systems will remain mounted (even if provided by a remote file server), and any other local filesystems will also be left mounted. During the transition down to single-user mode, all processes started by init or init.d scripts that should only be running in multi-user mode are killed. In addition, any process that has a utmpx entry will be killed. This last condition ensures that all port monitors started by the SAC are killed and all services started by these port monitors, including ttymon login services, are killed.
This request corresponds to a request for smf(7) to restrict the system milestone to svc:/milestone/single-user:default.
System console device.
This file is Obsolete and might be removed in a future release. Instead of obtaining values from this file, the init process reads properties for the svc:/system/environment:init service. To make changes that were formerly made by editing /etc/default/init, an administrator with the System Administrator or System Configuration rights profile can set the corresponding properties of the init service instance and refresh the instance.
This read-only file contains environment variables and their default values. The variables are:
Always set to localtime. To set the system time zone, an administrator must set the timezone/localtime property in timezone:default SMF service.
The mask (see umask(1)) that init uses and that every process inherits from the init process. If not set, init uses the mask it inherits from the kernel. Note that init always attempts to apply a umask of 022 before creating a file, regardless of the setting of CMASK
Character characterization information
Monetary formatting information
Numeric formatting information
Time formatting information
If set, all other LC_* environmental variables take-on this value.
If LC_ALL is not set, and any particular LC_* is also not set, the value of LANG is used for that particular environmental variable.
Controls process dispatching by init.
ioctl states of the console, as saved by init when single-user state is entered.
init state necessary to recover from failure.
User access and administration information.
History of user access and administration information.
A named pipe used for internal communication.
See attributes(7) for descriptions of the following attributes:
login(1), sh(1), stty(1), who(1), ioctl(2), kill(2), ctime(3C), pam(3PAM), termio(4I), environ(7), init.d(5), inittab(5), pam.conf(5), utmpx(5), attributes(7), pam_unix_session(7), smf(7), kernel(8), shutdown(8), su(8), svc.configd(8), svc.startd(8), ttymon(8)
If init finds that it is respawning an entry from /etc/inittab more than ten times in two minutes, it assumes that there is an error in the command string in the entry and generates an error message on the system console. It then refuses to respawn this entry until either five minutes has elapsed or it receives a signal from a user-spawned init command. This prevents init from eating up system resources when someone makes a typographical error in the inittab file, or a program is removed that is referenced in /etc/inittab.
init can be run only by a privileged user.
The S or s state must not be used indiscriminately in /etc/inittab. When modifying this file, it is best to avoid adding this state to any line other than initdefault.
If a default state is not specified in the initdefault entry in /etc/inittab, state 6 is entered. Consequently, the system will loop by going to firmware and rebooting continuously.
If the utmpx file cannot be created when booting the system, the system will boot to state “s” regardless of the state specified in the initdefault entry in /etc/inittab. This can occur if the /var file system is not accessible.
When a system transitions down to run level 1 or single user (run level S or s), the /etc/nologin file (see nologin(5)) is created. Upon subsequent transition to run level 2, 3, or 4 (multi-user state), the /etc/nologin file is removed.
init uses /var/run/initpipe, a named pipe, for internal communication.
When you shut down an image, services are shut down in reverse dependency order.