Go to main content

man pages section 8: System Administration Commands

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

puppet-config (8)

Name

puppet-config - Interact with Puppet's settings.

Synopsis

puppet config action [--section SECTION_NAME]

Description

PUPPET-CONFIG(8)                 Puppet manual                PUPPET-CONFIG(8)



NAME
       puppet-config - Interact with Puppet's settings.

SYNOPSIS
       puppet config action [--section SECTION_NAME]

DESCRIPTION
       This  subcommand  can  inspect  and modify settings from Puppet's 'pup-
       pet.conf' configuration file. For documentation about  individual  set-
       tings, see https://puppet.com/docs/puppet/latest/configuration.html.

OPTIONS
       Note  that any setting that's valid in the configuration file is also a
       valid long argument, although it may or may  not  be  relevant  to  the
       present action. For example, server and run_mode are valid settings, so
       you can specify --server <servername>, or --run_mode  <runmode>  as  an
       argument.

       See    the    configuration    file   documentation   at   https://pup-
       pet.com/docs/puppet/latest/configuration.html  for  the  full  list  of
       acceptable  parameters.  A  commented list of all configuration options
       can also be generated by running puppet with --genconfig.

       --render-as FORMAT
              The format in which to render output. The  most  common  formats
              are  json, s (string), yaml, and console, but other options such
              as dot are sometimes available.

       --verbose
              Whether to log verbosely.

       --debug
              Whether to log debug information.

       --section SECTION_NAME
              The section of the puppet.conf configuration  file  to  interact
              with.

              The  three most commonly used sections are 'main', 'server', and
              'agent'. 'Main' is the default, and is used by all Puppet appli-
              cations.  Other sections can override 'main' values for specific
              applications --- the 'server' section affects Puppet Server, and
              the 'agent' section affects puppet agent.

              Less  commonly  used is the 'user' section, which affects puppet
              apply. Any other section will be treated as the name of a legacy
              environment  (a  deprecated  feature),  and can only include the
              'manifest' and 'modulepath' settings.

ACTIONS
       delete - Delete a Puppet setting.
              SYNOPSIS

              puppet config delete [--section SECTION_NAME] setting

              DESCRIPTION

              Deletes a setting from the specified section.  (The  default  is
              the section 'main').

              NOTES

              By  default,  this action deletes the configuration setting from
              the 'main' configuration domain. Use the  '--section'  flags  to
              delete settings from other configuration domains.

       print - Examine Puppet's current settings.
              SYNOPSIS

              puppet config print [--section SECTION_NAME] all | setting [set-
              ting ...]

              DESCRIPTION

              Prints the value of a single setting or a list of settings.

              This action is a replacement interface to the information avail-
              able with puppet <subcommand> --configprint.

              NOTES

              By  default,  this action reads the general configuration in the
              'main' section. Use the '--section' and '--environment' flags to
              examine other configuration domains.

       set - Set Puppet's settings.
              SYNOPSIS

              puppet  config set [--section SECTION_NAME] [setting_name] [set-
              ting_value]

              DESCRIPTION

              Updates values in the puppet.conf configuration file.

              NOTES

              By default, this action manipulates  the  configuration  in  the
              'main'  section.  Use  the  '--section' flag to manipulate other
              configuration domains.

EXAMPLES
       delete

       Delete the setting 'setting_name' from the 'main' configuration domain:

       $ puppet config delete setting_name

       Delete the  setting  'setting_name'  from  the  'server'  configuration
       domain:

       $ puppet config delete setting_name --section server

       print

       Get puppet's runfile directory:

       $ puppet config print rundir

       Get a list of important directories from the server's config:

       $ puppet config print all --section server | grep -E "(path|dir)"

       set

       Set puppet's runfile directory:

       $ puppet config set rundir /var/run/puppetlabs

       Set the vardir for only the agent:

       $ puppet config set vardir /var/puppetlabs/puppet/cache --section agent

COPYRIGHT AND LICENSE
       Copyright 2011 by Puppet Inc. Apache 2 license; see COPYING



ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+--------------------------+
       |ATTRIBUTE TYPE |     ATTRIBUTE VALUE      |
       +---------------+--------------------------+
       |Availability   | system/management/puppet |
       +---------------+--------------------------+
       |Stability      | Volatile                 |
       +---------------+--------------------------+

NOTES
       Source  code  for open source software components in Oracle Solaris can
       be found at https://www.oracle.com/downloads/opensource/solaris-source-
       code-downloads.html.

       This     software     was    built    from    source    available    at
       https://github.com/oracle/solaris-userland.   The  original   community
       source was downloaded from  https://github.com/puppetlabs/puppet.

       Further information about this software can be found on the open source
       community website at http://puppetlabs.com/.



Puppet, Inc.                     January 2022                 PUPPET-CONFIG(8)