mountd - server for NFS mount requests and NFS access checks
/usr/lib/nfs/mountd [-v] [-r]
mountd is an RPC server that answers requests for NFS access information and file system mount requests. It reads the file /etc/dfs/sharetab to determine which file systems are available for mounting by which remote machines. See sharetab(5). nfsd running on the local server will contact mountd the first time an NFS client tries to access the file system to determine whether the client should get read-write, read-only, or no access. This access can be dependent on the security mode used in the remoted procedure call from the client. See share_nfs(8).
The command also provides information as to what file systems are mounted by which clients. This information can be printed using the showmount(8) command.
The mountd daemon is automatically invoked by share(8).
Only super user can run the mountd daemon.
Since mountd must be running for nfsd to function properly, mountd is automatically started by the svc:/network/nfs/server service.
Startup SMF parameters for mountd can be manipulated using the sharectl(8) command. The currently supported parameters are:
The NFS server only uses NFS versions in the range specified by these variables. Valid values or versions are: 2, 3, and 4. If one or both of these parameters are left unset, the default minimum version is 2, while the default maximum version is 4.
If the value of this property is none, the following rules apply:
A client can see only the shares that it is allowed to access.
A client cannot see access lists for the shares defined at server.
A client cannot see remote mounts from the server done by other clients.
If the value is full, these rules do not apply. The default value is full.
For example, to place the restrictions specified above for users of showmount(8), enter:
# sharectl set -p showmount_info=none nfs % sharectl get -p showmount_info nfs showmount_info=none
The options shown below are supported for NFSv2/v3 clients. They are not supported for Solaris NFSv4 clients.
Reject mount requests from clients. Clients that have file systems mounted will not be affected.
Run the command in verbose mode. Each time mountd determines what access a client should get, it will log the result to the console, as well as how it got that result.
shared file system table
See attributes(7) for descriptions of the following attributes:
Some routines that compare hostnames use case-sensitive string comparisons; some do not. If an incoming request fails, verify that the case of the hostname in the file to be parsed matches the case of the hostname called for, and attempt the request again.