utmpd - utmpx monitoring daemon
The utmpd daemon monitors and updates the /var/adm/utmpx file. See utmpx(5).
utmpd receives requests from pututxline(3C) by way of a named pipe. It maintains a table of processes and uses poll(2) on /proc files to detect process termination. When utmpd detects that a process has terminated, it checks that the process has removed its utmpx entry from /var/adm/utmpx. If the process' utmpx entry has not been removed, utmpd removes the entry. By periodically scanning the /var/adm/utmpx file, utmpd also monitors processes that are not in its table.
utmpd also periodically opens the /var/adm/wtmpx file. The wtmpx file's last access time is used by init(8) on reboot to determine when the operating system became unavailable if it did not shut down cleanly.
Run in debug mode, leaving the process connected to the controlling terminal. Write debugging information to standard output.
The following exit values are returned:
An error occurred.
You can set default values for the flags listed below. For example: SCAN_PERIOD=600
The number of seconds that utmpd sleeps between checks of /proc to see if monitored processes are still alive. The default is 300.
The maximum number of processes that utmpd attempts to monitor. The default value is 4096.
The number of seconds that utmpd sleeps between read accesses of the wtmpx file. The default is 60.
Directory containing files for processes whose utmpx entries are being monitored.
See attributes(7) for descriptions of the following attributes:
If the filesystem holding /var/adm/wtmpx is mounted with options which inhibit or defer access time updates, an unknown amount of error will be introduced into the utmp DOWN_TIME record's timestamp in the event of an uncontrolled shutdown (for example, a crash or loss of power). Controlled shutdowns will update the modify time of /var/adm/wtmpx, which will be used on the next boot to determine when the previous shutdown occurred, regardless of access time deferral or inhibition.
The utmpd service is managed by the service management facility, smf(7), under the service identifier:
The utmpd daemon was added in Solaris 2.4.