Go to main content

マニュアルページ セクション 8: システム管理コマンド

印刷ビューの終了

更新: 2018年8月8日
 
 

puppet-config (8)

名前

puppet-config - Interact with Puppet's settings.

形式

puppet config action [--section SECTION_NAME]

説明

PUPPET-CONFIG(8)                 Puppet manual                PUPPET-CONFIG(8)



NAME
       puppet-config - Interact with Puppet's settings.

SYNOPSIS
       puppet config action [--section SECTION_NAME]

DESCRIPTION
       This  subcommand  can  inspect  and modify settings from Puppet's 'pup-
       pet.conf' configuration file. For documentation about  individual  set-
       tings, see https://docs.puppetlabs.com/puppet/latest/reference/configu-
       ration.html.

OPTIONS
       Note that any setting that's valid in the configuration file is also  a
       valid  long  argument,  although  it  may or may not be relevant to the
       present action. For example, server and run_mode are valid settings, so
       you  can  specify  --server <servername>, or --run_mode <runmode> as an
       argument.

       See  the  configuration  file  documentation  at   https://docs.puppet-
       labs.com/puppet/latest/reference/configuration.html  for  the full list
       of acceptable parameters. A commented list of all configuration options
       can also be generated by running puppet with --genconfig.

       --render-as FORMAT
              The  format  in  which to render output. The most common formats
              are json, s (string), yaml, and console, but other options  such
              as dot are sometimes available.

       --verbose
              Whether to log verbosely.

       --debug
              Whether to log debug information.

       --section SECTION_NAME
              The  section  of  the puppet.conf configuration file to interact
              with.

              The three most commonly used sections are 'main', 'master',  and
              'agent'. 'Main' is the default, and is used by all Puppet appli-
              cations. Other sections can override 'main' values for  specific
              applications  --- the 'master' section affects puppet master and
              puppet cert, and the 'agent' section affects puppet agent.

              Less commonly used is the 'user' section, which  affects  puppet
              apply. Any other section will be treated as the name of a legacy
              environment (a deprecated feature), and  can  only  include  the
              'manifest' and 'modulepath' settings.

ACTIONS
       delete - Delete a Puppet setting.
              SYNOPSIS

              puppet config delete [--section SECTION_NAME] (setting

              DESCRIPTION

              Deletes  a  setting  from the specified section. (The default is
              the section 'main').

              NOTES

              By default, this action deletes the configuration  setting  from
              the  'main'  configuration  domain. Use the '--section' flags to
              delete settings from other configuration domains.

       print - Examine Puppet's current settings.
              SYNOPSIS

              puppet config print  [--section  SECTION_NAME]  (all  |  setting
              [setting ...]

              DESCRIPTION

              Prints the value of a single setting or a list of settings.

              This  action is an alternate interface to the information avail-
              able with puppet <subcommand> --configprint.

              NOTES

              By default, this action reads the general configuration  in  the
              'main' section. Use the '--section' and '--environment' flags to
              examine other configuration domains.

       set - Set Puppet's settings.
              SYNOPSIS

              puppet config set [--section SECTION_NAME] [setting_name]  [set-
              ting_value]

              DESCRIPTION

              Updates values in the puppet.conf configuration file.

              NOTES

              By  default,  this  action  manipulates the configuration in the
              'main' section. Use the '--section'  flag  to  manipulate  other
              configuration domains.

EXAMPLES
       delete

       Delete the setting 'setting_name' from the 'main' configuration domain:

       $ puppet config delete setting_name

       Delete  the  setting  'setting_name'  from  the  'master' configuration
       domain:

       $ puppet config delete setting_name --section master

       print

       Get puppet's runfile directory:

       $ puppet config print rundir

       Get a list of important directories from the master's config:

       $ puppet config print all --section master | grep -E "(path|dir)"

       set

       Set puppet's runfile directory:

       $ puppet config set rundir /var/run/puppetlabs

       Set the vardir for only the agent:

       $ puppet config set vardir /var/puppetlabs/puppet/cache --section agent

COPYRIGHT AND LICENSE
       Copyright 2011 by Puppet Inc. Apache 2 license; see COPYING



ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+--------------------------+
       |ATTRIBUTE TYPE |     ATTRIBUTE VALUE      |
       +---------------+--------------------------+
       |Availability   | system/management/puppet |
       +---------------+--------------------------+
       |Stability      | Volatile                 |
       +---------------+--------------------------+
NOTES
       This    software    was    built    from    source     available     at
       https://github.com/oracle/solaris-userland.    The  original  community
       source was  downloaded  from   https://github.com/puppetlabs/puppet/ar-
       chive/5.5.0.tar.gz

       Further information about this software can be found on the open source
       community website at http://puppetlabs.com/.



Puppet, Inc.                      March 2018                  PUPPET-CONFIG(8)