Go to main content

man pages section 1: User Commands

Exit Print View

Updated: Thursday, June 13, 2019
 
 

gpgrt-config (1)

Name

gpgrt-config - Script to get information about the installed version of libgpg-error

Synopsis

gpgrt-config [options]

Description

GPGRT-CONFIG(1)                      GnuPG                     GPGRT-CONFIG(1)



NAME
       gpgrt-config - Script to get information about the installed version of
       libgpg-error

SYNOPSIS
       gpgrt-config [options]


DESCRIPTION
       gpgrt-config is a tool that is used to configure to determine the  com-
       piler and linker flags that should be used to compile and link programs
       that use Libgpg-error. It is also used internally to the .m4 macros for
       GNU autoconf that are included with Libgpg-error.


OPTIONS
       gpgrt-config accepts the following options:



       --mt   Provide  output appropriate for multithreaded programs.  --mt is
              only useful when combined with other options, and  must  be  the
              first option if present.


       --version
              Print  the  currently  installed  version of Libgpg-error on the
              standard output.


       --libs Print the linker flags that are  necessary  to  link  a  program
              using Libgpg-error.


       --cflags
              Print the compiler flags that are necessary to compile a program
              using Libgpg-error.


       --prefix=prefix
              If specified, use prefix instead of the installation prefix that
              Libgpg-error  was  built  with when computing the output for the
              --cflags and --libs options.  This option is also used  for  the
              exec  prefix  if  --exec-prefix  was not specified.  This option
              must be specified before any --libs or --cflags options.


       --exec-prefix=prefix
              If specified, use prefix instead of the installation exec prefix
              that  Libgpg-error  was built with when computing the output for
              the --cflags and --libs options.  This option must be  specified
              before any --libs or --cflags options.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+-------------------------------+
       |ATTRIBUTE TYPE |       ATTRIBUTE VALUE         |
       +---------------+-------------------------------+
       |Availability   | library/security/libgpg-error |
       +---------------+-------------------------------+
       |Stability      | Pass-through volatile         |
       +---------------+-------------------------------+
NOTES
       This     software     was    built    from    source    available    at
       https://github.com/oracle/solaris-userland.   The  original   community
       source   was   downloaded   from   https://gnupg.org/ftp/gcrypt/libgpg-
       error/libgpg-error-1.36.tar.bz2

       Further information about this software can be found on the open source
       community website at https://gnupg.org/software/libgpg-error/.



Libgpg-error 1.36                 2019-05-12                   GPGRT-CONFIG(1)