line - read one line
The line utility copies one line (up to and including a new-line) from the standard input and writes it on the standard output. It returns an exit status of 1 on EOF and always prints at least a new-line. It is often used within shell files to read from the user's terminal.
Exit status is:
End-of-file on input.
See attributes(7) for descriptions of the following attributes: