Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

audio_dev_add_info(9F)

Name

audio_dev_set_description, audio_dev_set_version, audio_dev_add_info - set human-readable information fields for an audio device

Synopsis

#include <sys/audio/audio_driver.h>

void audio_dev_set_description(audio_dev_t *adev, const char *desc);
void audio_dev_set_version(audio_dev_t *adev, const char *vers);
void audio_dev_add_info(audio_dev_t *adev, const char *info);

Parameters

adev

pointer to an audio device allocated with audio_dev_alloc(9F)

desc

a short description of the device

vers

a human-readable version for the device

info

additional human-readable details about the device

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_dev_set_description() and audio_dev_version() functions set strings describing the device for applications to display this information to users.

The audio_dev_add_info() function provides more detailed information, such as codec details. Successive calls to this function are additive. Each addition will represent one line of output in any detailed device report.

The strings are copied by the framework, so drivers may use local or temporary storage for them. They must be properly terminated with null bytes. Only the ASCII character set is supported.

The supplied strings may be truncated to 16 characters by some applications.

Context

These functions may be called from user or kernel context only.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), audio(7D), audio_dev_alloc(9F)