Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_driver_major(9F)

Name

ddi_driver_major - return driver's major device number

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

major_t ddi_driver_major(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI)

Description

ddi_driver_major() returns the major device number for the driver associated with the supplied dev_info node. This value can then be used as an argument to makedevice(9F) to construct a complete dev_t.

Parameters

dip

A pointer to the device's dev_info structure.

Return Values

ddi_driver_major() returns the major number of the driver bound to a device, if any, or DDI_MAJOR_T_NONE otherwise.

Context

ddi_driver_major() can be called from kernel or interrupt context.

See Also

ddi_driver_name(9F)

Writing Device Drivers