Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

csx_DeregisterClient(9F)

Name

csx_DeregisterClient - remove client from Card Services list

Synopsis

#include <sys/pccard.h> 

int32_t csx_DeregisterClient(client_handle_t ch);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

ch

Client handle returned from csx_RegisterClient(9F).

Description

This function removes a client from the list of registered clients maintained by Card Services. The Client Handle returned by csx_RegisterClient(9F) is passed in the client_handle_t argument.

The client must have returned all requested resources before this function is called. If any resources have not been released, CS_IN_USE is returned.

Return Values

CS_SUCCESS

Successful operation.

CS_BAD_HANDLE

Client handle is invalid.

CS_IN_USE

Resources not released by this client.

CS_UNSUPPORTED_FUNCTION

No PCMCIA hardware installed.

Context

This function may be called from user or kernel context.

See Also

csx_RegisterClient(9F)

PC Card 95 Standard, PCMCIA/JEIDA

Warnings

Clients should be prepared to receive callbacks until Card Services returns from this request successfully.