Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

bcanput(9F)

Name

bcanput - test for flow control in specified priority band

Synopsis

#include <sys/stream.h>

int bcanput(queue_t *q, unsigned char pri);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the message queue.

pri

Message priority.

Description

The bcanput() function searches through the stream (starting at q) until it finds a queue containing a service routine where the message can be enqueued, or until it reaches the end of the stream. If found, the queue containing the service routine is tested to see if there is room for a message of priority pri in the queue.

If pri is 0, bcanput () is equivalent to a call with canput(9F).

canputnext(q) and bcanputnext(q, pri) should always be used in preference to canput(q→q_next) and bcanput(q→q_next, pri) respectively.

Return Values

1

If a message of priority pri can be placed on the queue.

0

If the priority band is full.

Context

The bcanput() function can be called from user, interrupt, or kernel context.

See Also

bcanputnext(9F), canput(9F), canputnext(9F), putbq(9F), putnext(9F)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide

Warnings

Drivers are responsible for both testing a queue with bcanput () and refraining from placing a message on the queue if bcanput() fails.