Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_get_attr(9F)

Name

ddi_dma_get_attr - get the device DMA attribute structure from a DMA handle

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_get_attr(ddi_dma_handle_t handle, ddi_dma_attr_t *attrp);

Interface Level

Solaris DDI specific (Solaris DDI). This interface is obsolete.

Parameters

handle

The handle filled in by a call to ddi_dma_alloc_handle(9F).

attrp

Pointer to a buffer suitable for holding a DMA attribute structure. See ddi_dma_attr(9S).

Description

ddi_dma_get_attr() is used to get a ddi_dma_attr(9S) structure. This structure describes the attributes of the DMA data path to which any memory object bound to the given handle will be subject.

Return Values

DDI_SUCCESS

Successfully passed back attribute structure in buffer pointed to by attrp.

DDI_DMA_BADATTR

A valid attribute structure could not be passed back.

Context

ddi_dma_get_attr() can be called from any context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Obsolete

See Also

ddi_dma_alloc_handle(9F), ddi_dma_attr(9S)