Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_report_dev(9F)

Name

ddi_report_dev - announce a device

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

void ddi_report_dev(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

a pointer the device's dev_info structure.

Description

ddi_report_dev() prints a banner at boot time, announcing the device pointed to by dip. The banner is always placed in the system logfile (displayed by dmesg(1M)), but is only displayed on the console if the system was booted with the verbose (–v) argument.

Context

ddi_report_dev() can be called from user context.

See Also

dmesg(1M), kernel(1M)

Writing Device Drivers for Oracle Solaris 11.3