Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ldi_dump(9F)

Name

ldi_dump - Issue a dump request to a device

Synopsis

#include <sys/sunldi.h>

int ldi_dump(ldi_handle_t lh, caddr_t addr, daddr_t blkno, int nblk);

Parameters

lh

Layered handle.

addr

Area dump address.

blkno

Block offset to dump memory.

nblk

Number of blocks to dump.

Description

The ldi_dump() function passes a dump request to the device entry point specified by the layered handle. This operation is supported for block devices.

Return Values

The ldi_dump() function returns 0 upon success. If a failure occurs before the request is passed on to the device, the possible return values are shown below. Otherwise any other error number may be returned by the device.

EINVAL

Invalid input parameters.

ENOTSUP

Operation is not supported for this device.

Context

These functions may be called from user or kernel context.