Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

kstat_delete(9F)

Name

kstat_delete - remove a kstat from the system

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>

void kstat_delete(kstat_t *ksp);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

ksp

Pointer to a currently installed kstat(9S) structure.

Description

kstat_delete() removes ksp from the kstat chain and frees all associated system resources.

Return Values

None.

Context

kstat_delete() can be called from any context.

See Also

kstat_create(9F), kstat_install(9F), kstat_named_init(9F), kstat(9S)

Writing Device Drivers for Oracle Solaris 11.3

Notes

When calling kstat_delete(), the driver must not be holding that kstat's ks_lock. Otherwise, it may deadlock with a kstat reader.