Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

bioerror(9F)

Name

bioerror - indicate error in buffer header

Synopsis

#include <sys/types.h>
#include <sys/buf.h>
#include <sys/ddi.h>

void bioerror(struct buf *bp, int error);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

bp

Pointer to the buf(9S) structure describing the transfer.

error

Error number to be set, or zero to clear an error indication.

Description

If error is non-zero, bioerror() indicates an error has occured in the buf(9S) structure. A subsequent call to geterror(9F) will return error.

If error is 0, the error indication is cleared and a subsequent call to geterror(9F) will return 0.

Context

bioerror() can be called from any context.

See Also

strategy(9E), geterror(9F), getrbuf(9F), buf(9S)