Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_get_cred(9F)

Name

ddi_get_cred - returns a pointer to the credential structure of the caller

Synopsis

#include <sys/types.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

cred_t *ddi_get_cred(void)

Interface Level

Solaris DDI specific (Solaris DDI).

Description

ddi_get_cred() returns a pointer to the user credential structure of the caller.

Return Values

ddi_get_cred() returns a pointer to the caller's credential structure.

Context

ddi_get_cred() can be called from user context only.

See Also

Writing Device Drivers for Oracle Solaris 11.3