Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

esbbcall(9F)

Name

esbbcall - call function when buffer is available

Synopsis

#include <sys/stream.h> 

bufcall_id_t esbbcall(uint_t 
pri, void (*func)(
void *arg), 
     void(arg));

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

pri

Priority of allocation request (to be used by allocb(9F) function, called by esbbcall ()).

func

Function to be called when buffer becomes available.

arg

Argument to func.

Description

The esbbcall() function, like bufcall(9F), serves as a timeout(9F) call of indeterminate length. If esballoc(9F) is unable to allocate a message and data block header to go with its externally supplied data buffer, esbbcall() can be used to schedule the routine func, to be called with the argument arg when a buffer becomes available. The func argument can be a routine that calls esballoc(9F) or it may be another kernel function.

Return Values

On success, a bufcall IDis returned. On failure, 0 is returned. The value returned from a successful call should be saved for possible future use with unbufcall () should it become necessary to cancel the esbbcall() request (as at driver close time).

Context

The esbbcall() function can be called from user, interrupt, or kernel context.

See Also

allocb(9F), bufcall(9F), esballoc(9F), timeout(9F), datab(9S), unbufcall(9F)

Writing Device Drivers for Oracle Solaris 11.3 STREAMS Programming Guide