Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_protocol_walk(9F)

Name

net_protocol_walk - step through the list of registered network protocols

Synopsis

#include <sys/neti.h>

net_handle_t net_protocol_walk(netid_t stack_id, net_handle_t net);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

stack_id

the IP stack instance ID obtained by a calling getzoneid(3C) and typecasting its return value to netid_t

net

value returned from a successful call to net_protocol_lookup(9F).

Description

The net_protocol_walk() function walks through all of the network protocols that have been registered with this interface. The initial call to net_protocol_walk() should be made by passing in NULL as the value for net. When this function returns NULL, the end of the list has been reached.

A caller of net_protocol_walk() is required to walk through the entire list of network protocols, until NULL is returned or, when finished with using the value returned, pass it into a call to net_protocol_release(9F).

Return Values

The net_protocol_walk() function returns NULL when the end of the list is returned. Otherwise, it returns a non-NULL value as a token for being passed into other function calls within this interface.

Context

The net_protocol_walk() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_protocol_lookup(9F), net_protocol_release(9F), attributes(5)