Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

usb_get_addr(9F)

Name

usb_get_addr - Retrieve device USB address

Synopsis

#include <sys/usb/usba.h>

int usb_get_addr(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

dip

Pointer to the device's dev_info structure.

Description

The usb_get_addr() function returns the current USB bus address for debugging purposes. The returned address is unique for a specific USB bus, and may be replicated if multiple host controller instances are present on the system.

Return Values

On success: USB device address.

On failure: returns 0. Fails if dip is NULL.

Context

May be called from user, kernel or interrupt context.

Examples

int usb_addr;

usb_addr = usb_get_addr(dip);

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI-based systems
Interface Stability
Committed
Availability
system/io/usb

See Also

attributes(5), usb_pipe_open(9F)