Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_instance_register(9F)

Name

net_instance_register - register a set of instances to occur with IP instance events

Synopsis

#include <sys/neti.h>

int net_instance_register(net_instance_t *instances);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

instances

must be a pointer returned by net_instance_alloc(9F).

Description

The net_instance_register() function attempts to record the set of functions passed by instances that are to be called when an event related to IP instance maintenance occurs.

Return Values

If the net_instance_register() function succeeds, DDI_SUCCESS is returned. Otherwise, DDI_FAILURE is returned to indicate failure due to the name in the instance already being present.

Context

The net_instance_register() function may be called from user or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_instance_alloc(9F), net_instance_unregister(9F), attributes(5), net_instance_t(9S)