Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

pollwakeup(9F)

Name

pollwakeup - inform a process that an event has occurred

Synopsis

#include <sys/poll.h>

void pollwakeup(struct pollhead *php, short event);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

php

Pointer to a pollhead structure.

event

Event to notify the process about.

Description

The pollwakeup() function wakes a process waiting on the occurrence of an event. It should be called from a driver for each occurrence of an event. The pollhead structure will usually be associated with the driver's private data structure associated with the particular minor device where the event has occurred. See chpoll(9E) and poll(2) for more detail.

Context

The pollwakeup() function can be called from user, interrupt, or kernel context.

See Also

poll(2), chpoll(9E)

Writing Device Drivers for Oracle Solaris 11.3

Notes

Driver defined locks should not be held across calls to this function.