Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

flushband(9F)

Name

flushband - flush messages for a specified priority band

Synopsis

#include <sys/stream.h>

void flushband(queue_t *q, unsigned char pri, int flag);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the queue.

pri

Priority of messages to be flushed.

flag

Valid flag values are:

FLUSHDATA

Flush only data messages (types M_DATA, M_DELAY, M_PROTO, and M_PCPROTO ).

FLUSHALL

Flush all messages.

Description

The flushband() function flushes messages associated with the priority band specified by pri. If pri is 0, only normal and high priority messages are flushed. Otherwise, messages are flushed from the band pri according to the value of flag.

Context

The flushband() function can be called from user, interrupt, or kernel context.

See Also

flushq(9F)

Writing Device Drivers for Oracle Solaris 11.3 STREAMS Programming Guide