Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

hook_free(9F)

Name

hook_free - free a hook_t data structure

Synopsis

#include <sys/hook.h>

void hook_free(hook_t * hook);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

hook

pointer returned by hook_alloc(9F).

Description

The hook_free() function frees a hook_t structure that was originally allocated by hook_alloc(9F).

Context

The hook_free() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

hook_alloc(9F), hook_t(9S)