Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

mexchange(9F)

Name

mexchange - Exchange one message for another

Synopsis

#include <sys/stream.h>
#include <sys/strsun.h>

mblk_t *mexchange(queue_t *wq, mblk_t *mp, size_t size, 
     uchar_t type, int32_t primtype);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

wq

Optionally, write queue associated with the read queue to be used on failure (see below).

mp

Optionally, the message to exchange.

size

Size of the returned message.

type

Type of the returned message.

primtype

Optionally, a 4 byte value to store at the beginning of the returned message.

Description

The mexchange() function exchanges the passed in message for another message of the specified size and type.

If mp is not NULL, is of at least size bytes, and has only one reference (see dupmsg(9F)), mp is converted to be of the specified size and type. Otherwise, a new message of the specified size and type is allocated. If allocation fails, and wq is not NULL, merror(9F) attempts to send an error to the stream head.

Finally, if primtype is not -1 and size is at least 4 bytes, the first 4 bytes are assigned to be primtype. This is chiefly useful for STREAMS-based protocols such as DLPI and TPI which store the protocol message type in the first 4 bytes of each message.

Return Values

A pointer to the requested message is returned on success. NULL is returned on failure.

Context

This function can be called from user, kernel or interrupt context.

See Also

dupmsg(9F), merror(9F)

STREAMS Programming Guide