Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_zoneidtonetid(9F)

Name

net_zoneidtonetid - map a zoneid_t struture identifier to a netid_t structure

Synopsis

#include <sys/neti.h>

netid_t net_zoneidtonetid(const zoneid_t zone);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

zone

valid zoneid_t structure that refers to a running zone.

Description

The net_zoneidtonetid() function maps the given zoneid_t structure (used to represent a zone that is currently running) into a netid_t structure that is associated with the IP instance supporting network functions for that zone.

Return Values

The net_zoneidtonetid() function returns -1 if no mapping took place. Otherwise, it returns the netid_t structure currently used by the zoneid_t structure. For zones that are using a shared IP instance, the netid_t structure for the instance owned by the global zone is returned.

Context

The net_zoneidtonetid() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_netidtozonid(9F), attributes(5)