Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_protocol_release(9F)

Name

net_protocol_release - indicate that a reference to a network protocol is no longer required

Synopsis

#include <sys/neti.h>

int net_protocol_release(net_data_t *net);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

Description

The net_protocol_release() function indicates to the network information framework that the caller is no longer interested in any knowledge about the network protocol to which the parameter being passed through applies.

Return Values

The net_protocol_release() function returns:

–1

The value passed in is unknown to this framework.

0

Successful completion.

1

Unsuccessful because this function has been called too many times.

Context

The net_protocol_release() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_protocol_lookup(9F), net_protocol_walk(9F), attributes(5)