Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

freemsg(9F)

Name

freemsg - free all message blocks in a message

Synopsis

#include <sys/stream.h>

void freemsg(mblk_t *mp);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

mp

Pointer to the message blocks to be deallocated. mblk_t is an instance of the msgb(9S) structure. If mp is NULL, freemsg() immediately returns.

Description

The freemsg() function calls freeb(9F) to free all message and data blocks associated with the message pointed to by mp.

Context

The freemsg() function can be called from user, interrupt, or kernel context.

Examples

Example 1 Using freemsg()

See copymsg(9F).

See Also

copymsg(9F), freeb(9F), msgb(9S)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide

Notes

The behavior of freemsg() when passed a NULL pointer is Solaris-specific.