Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_routeto(9F)

Name

net_routeto - indicate which network interface packets are sent

Synopsis

#include <sys/neti.h>

phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address, 
     struct sockaddr *nexthop);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

address

network address to find a path out of the machine for.

nexthop

pointer to the sockaddr structure in which to store the address of the next hop. If this information is not required, the value NULL may be passed instead.

Description

The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it.

Return Values

The net_routeto() function returns:

–1

The network protocol does not support this function.

0

This function cannot find a route for the address given.

>0

Indicates which network interface can be used to reach the given address.

Context

The net_routeto() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F), attributes(5)