Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

qenable(9F)

Name

qenable - enable a queue

Synopsis

#include <sys/stream.h>
#include <sys/ddi.h>

void qenable(queue_t *q);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the queue to be enabled.

Description

The qenable() function adds the queue pointed to by q to the list of queues whose service routines are ready to be called by the STREAMS scheduler.

Context

The qenable() function can be called from user, interrupt, or kernel context.

Examples

See the dupb(9F) function page for an example of the qenable().

See Also

dupb(9F)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide