Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_kstat_delete(9F)

Name

net_kstat_delete - remove a kstat for a specific instance of IP from the system

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/neti.h>

void net_kstat_delete(netid_t netid, kstat_t *ksp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

netid

IP instance identifier.

ksp

Pointer to a currently installed kstat(9S) structure.

Description

The net_kstat_delete() function removes ksp from the kstat chain and frees all associated system resources. See kstat_delete(9F) for a complete discussion of this function.

Return Values

If successful, net_kstat_delete() returns a pointer to the allocated kstat. NULL is returned upon failure.

Context

The net_kstat_delete() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

kstat_create(9F), kstat_delete(9F), net_kstat_create(9F), hook_t(9S), kstat_named(9S)