Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_no_info(9F)

Name

ddi_no_info - stub for getinfo(9E)

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_no_info(dev_info_t *dip, ddi_info_cmd_t infocmd, void *arg, 
    void **result

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

dev_info_t *dip

Pointer to dev_info structure.

ddi_info_cmd_t infocmd

Command argument. Valid command values are: DDI_INFO_DEVT2DEVINFO and DDI_INFO_DEVT2INSTANCE.

void *arg

Command-specific argument.

void **result

Pointer to where the requested information is stored.

Description

The ddi_no_info() function always returns DDI_FAILURE. It is provided as a convenience routine for drivers not providing a cb_ops(9S) or for network drivers only providing DLPI-2 services. Such drivers can use ddi_no_info() in the devo_getinfo entry point (see getinfo(9E)) of the dev_ops(9S) structure.

Return Values

The ddi_no_info() function always returns DDI_FAILURE.

See Also

getinfo(9E), qassociate(9F), cb_ops(9S), dev_ops(9S)