Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

strqset(9F)

Name

strqset - change information about a queue or band of the queue

Synopsis

#include <sys/stream.h>

int strqset(queue_t *q, qfields_t what, unsigned char pri, intptr_t val);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the queue.

what

Field of the queue structure (or the specified priority band) to return information about. Valid values are one of:

QHIWAT

High water mark.

QLOWAT

Low water mark.

QMAXPSZ

Largest packet accepted.

QMINPSZ

Smallest packet accepted.

pri

Priority band of interest.

val

The value for the field to be changed.

Description

The strqset() function gives drivers and modules a way to change information about a queue or a particular band of a queue without directly accessing STREAMS data structures.

Return Values

On success, 0 is returned. EINVAL is returned if an undefined attribute is specified.

Context

The strqset() function can be called from user, interrupt, or kernel context.

See Also

strqget(9F), queue(9S)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide

Notes

When lowering existing values, set QMINPSZ before setting QMAXPSZ; when raising existing values, set QMAXPSZ before setting QMINPSZ.