Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_instance_unregister(9F)

Name

net_instance_unregister - disable a set of instances

Synopsis

#include <sys/neti.h>

void net_instance_unregister(net_instance_t *instances);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

instances

must be a pointer returned by net_instance_alloc(9F).

Description

The net_instance_unregister() function removes the set of instances that were previously registered with the net_instance_register() function.

Return Values

If the net_instance_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered.

Context

The net_instance_unregister() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_instance_alloc(9F), net_instance_register(9F), attributes(5), net_instance_t(9S)