Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_mem_free(9F)

Name

ddi_dma_mem_free - free previously allocated memory

Synopsis

#include <sys/ddi.h> 
#include <sys/sunddi.h>

void ddi_dma_mem_free(ddi_acc_handle_t *handlep);

Parameters

handlep

Pointer to the data access handle previously allocated by a call to ddi_dma_mem_alloc(9F).

Interface Level

Solaris DDI specific (Solaris DDI).

Description

ddi_dma_mem_free() deallocates the memory acquired by ddi_dma_mem_alloc(9F). In addition, it destroys the data access handle handlep associated with the memory.

Context

ddi_dma_mem_free() can be called from user, kernel, or interrupt context.

See Also

ddi_dma_mem_alloc(9F)

Writing Device Drivers for Oracle Solaris 11.3