Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_slaveonly(9F)

Name

ddi_slaveonly - tell if a device is installed in a slave access only location

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_slaveonly(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

A pointer to the device's dev_info structure.

Description

The ddi_slaveonly() function tells the caller if the bus, or part of the bus that the device is installed on, does not permit the device to become a DMA master, that is, whether the device has been installed in a slave access only slot.

Return Values

DDI_SUCCESS

The device has been installed in a slave access only location.

DDI_FAILURE

The device has not been installed in a slave access only location.

Context

The ddi_slaveonly() function can be called from user, interrupt, or kernel context.

See Also

Writing Device Drivers for Oracle Solaris 11.3