Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

canput(9F)

Name

canput - test for room in a message queue

Synopsis

#include <sys/stream.h>

int canput(queue_t *q);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the message queue.

Description

canput() searches through the stream (starting at q) until it finds a queue containing a service routine where the message can be enqueued, or until it reaches the end of the stream. If found, the queue containing the service routine is tested to see if there is room for a message in the queue.

canputnext(q) and bcanputnext(q, pri ) should always be used in preference to canput(q→q_next) and bcanput(q →q_next, pri) respectively.

Return Values

1

If the message queue is not full.

0

If the queue is full.

Context

canput() can be called from user or interrupt context.

See Also

bcanput(9F), bcanputnext(9F), canputnext(9F), putbq(9F), putnext(9F)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide

Warnings

Drivers are responsible for both testing a queue with canput() and refraining from placing a message on the queue if canput() fails.