Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ldi_ev_get_type(9F)

Name

ldi_ev_get_type - get event name string from event cookie

Synopsis

#include <sys/sunldi.h>

int ldi_ev_get_type(ldi_ev_cookie_t cookie);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

ldi_ev_cookie_t cookie

An opaque event cookie for the event type returned by a previous call to ldi_ev_get_cookie(9F).

Description

The ldi_ev_get_type() function returns the event string represented by the LDI event cookie “cookie”.

Return Values

On success, this function returns the event string represented by “cookie”. On failure, this function returns NULL.

Context

This function can be called from user and kernel contexts only.

See Also

ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F), ldi_ev_remove_callbacks(9F)