Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_ispartialchecksum(9F)

Name

net_ispartialchecksum - indicate if a packet is being scheduled for hardware checksum calculation

Synopsis

#include <sys/neti.h>

int net_ispartialchecksum(const net_data_t net, mblk_t *mb);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

mb

the mblk structure holding a packet that is the subject of this query.

Description

The net_ispartialchecksum() function looks at the fields within the mblk structure to determine if the packet contained inside contains headers with only partial checksum values. Partial checksum values are stored inside headers when the calculation of the complete checksum is being handled by the hardware.

Return Values

The net_ispartialchecksum() function returns:

–1

The network protocol does not support this function.

0

The packet does not contain partial checksums.

If a packet is marked for hardware checksum'ing, the following values are returned:

NET_HCK_L3_FULL

Complete layer 3 checksum calculated

NET_HCK_L3_PART

Partial layer 3 checksum calculated

NET_HCK_L4_FULL

Complete layer 4 checksum calculated

NET_HCK_L4_PART

Partial layer 4 checksum calculated

Context

The net_ispartialchecksum() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_isvalidchecksum(9F), net_protocol_lookup(9F), attributes(5)