Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

csx_ReleaseConfiguration(9F)

Name

csx_ReleaseConfiguration - release PC Card and socket configuration

Synopsis

#include <sys/pccard.h>

int32_t csx_ReleaseConfiguration(client_handle_t ch, release_config_t *rc);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

ch

Client handle returned from csx_RegisterClient(9F).

rc

Pointer to a release_config_t structure.

Description

This function returns a PC Card and socket to a simple memory only interface and sets the card to configuration zero by writing a 0 to the PC card's COR (Configuration Option Register).

Card Services may remove power from the socket if no clients have indicated their usage of the socket by an active csx_RequestConfiguration(9F) or csx_RequestWindow(9F).

Card Services is prohibited from resetting the PC Card and is not required to cycle power through zero (0) volts.

After calling csx_ReleaseConfiguration() any resources requested via the request functions csx_RequestIO(9F), csx_RequestIRQ(9F), or csx_RequestWindow(9F) that are no longer needed should be returned to Card Services via the corresponding csx_ReleaseIO(9F), csx_ReleaseIRQ(9F), or csx_ReleaseWindow(9F) functions. csx_ReleaseConfiguration () must be called to release the current card and socket configuration before releasing any resources requested by the driver via the request functions named above.

Structure Members

The structure members of release_config_t are:

uint32_t     Socket;     /* socket number */

The Socket field is not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.

Return Values

CS_SUCCESS

Successful operation.

CS_BAD_HANDLE

Client handle is invalid or csx_RequestConfiguration(9F) not done.

CS_BAD_SOCKET

Error getting or setting socket hardware parameters.

CS_NO_CARD

No PC card in socket.

CS_UNSUPPORTED_FUNCTION

No PCMCIA hardware installed.

Context

This function may be called from user or kernel context.

See Also

csx_RegisterClient(9F), csx_RequestConfiguration(9F), csx_RequestIO(9F), csx_RequestIRQ(9F), csx_RequestWindow(9F)

PC Card 95 Standard, PCMCIA/JEIDA