Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_getpmtuenabled(9F)

Name

net_getpmtuenabled - determine if path MTU discovery is enabled for a network protocol

Synopsis

#include <sys/neti.h>

int net_getpmtuenabled(const net_data_t net);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

Description

The net_getpmtuenabled() function returns a value to indicate whether or not path MTU (PMTU) discovery is enabled for this network protocol.

Return Values

The net_getpmtuenabled() function returns:

–1

The network protocol does not support this function.

0

PATH MTU discovery is disabled.

1

PATH MTU discovery is enabled.

Context

The net_getpmtuenabled() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_getmtu(9F), net_protocol_lookup(9F)