Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_instance_alloc(9F)

Name

net_instance_alloc - allocate a net_instance_t structure

Synopsis

#include <sys/neti.h>

net_instance_t *net_instance_alloc(const int version);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

version

must always be the symbol NETI_VERSION.

Description

The net_instance_alloc() function allocates a net_instance_t structure, returning a pointer for the caller to use.

Return Values

Upon success, net_instance_alloc() returns a pointer to the allocated net_instance_t structure. On failure, it returns a NULL pointer.

Context

The net_instance_alloc() function may be called from user or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_instance_free(9F), attributes(5), net_inject_t(9S)