Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

kiconv_close(9F)

Name

kiconv_close - code conversion descriptor deallocation function

Synopsis

#include <sys/errno.h>
#include <sys/sunddi.h>

int kiconv_close(kiconv_t cd);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

cd

Code conversion descriptor to be deallocated.

Description

The kiconv_close() function deallocates the conversion descriptor cd and all other associated resources allocated by the kiconv_open() function.

Return Values

Upon successful completion, kiconv_close() returns 0; otherwise, it returns the following errno value to indicate the error:

EBADF

The code conversion descriptor is invalid.

Context

kiconv_close() can be called from user or interrupt context.

Examples

Example 1 Closing the Code Conversion

The following example shows how to close the code conversion descriptor with error checking:

if (kiconv_close(cd) == EBADF) {
         /* Code conversion descriptor is invalid. */
         return (-1);
}

The following example shows how to close the code conversion descriptor without error checking:

(void) kiconv_close(cd);

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

iconv(3C), iconv_close(3C), iconv_open(3C), u8_strcmp(3C), u8_textprep_str(3C), u8_validate(3C), uconv_u16tou32(3C), uconv_u16tou8(3C), uconv_u32tou16(3C), uconv_u32tou8(3C), uconv_u8tou16(3C), uconv_u8tou32(3C), attributes(5), kiconv(9F), kiconvstr(9F) , kiconv_open(9F), u8_strcmp(9F), u8_textprep_str(9F), u8_validate(9F), uconv_u16tou32(9F), uconv_u16tou8(9F), uconv_u32tou16(9F), uconv_u32tou8(9F), uconv_u8tou16(9F), uconv_u8tou32(9F)

The Unicode Standard

http://www.unicode.org/standard/standard.html